Outils pour utilisateurs


La version Linux est pour l'instant expérimentale. Un paquet Debian est disponible en téléchargement. C'est un paquet généré automatiquement par l'outil de build Gradle. Des contributeurs devraient prochainement construire un paquet plus généraliste et probablement plus conforme aux normes en vigueur. Le répertoire cible du programme est /opt/Logfly5.

A l'issue de l'installation, un dossier .logfly sera créé dans le home. Ce dossier contient le ou les carnets de vol et le fichier de configuration. Si vous utilisiez Logfly 4, il suffit de rapatrier le ou les fichiers .db qui contenait les vols dans ce dossier. Pour plus d'explications sur ce transfert consulter la FAQ sur le changement d'ordinateur.

Sur Ubuntu, le paquet Debian s'installe automatiquement à condition de lu avoir donner les autorisations nécessaires. Sinon un classique _sudo dpkg -i logfly5-xx.deb_ fait l'affaire.

 La première utilisation d'un Flymaster ou d'un Flytec renverra un message d'erreur  : 
 Permission non accordée
 

Il sera en effet nécessaire de lui accorder des droits. Si par exemple le Flymaster est reconnu sous /dev/ttyACM0, il faudra faire un :

sudo chmod 666 /dev/ttyACM0

Cependant cette autorsation ne sera valable que pour la session en cours. Pour la rendre permanente, il faudra mettre en place un fichier de règles pour le système UDEV. Explications sur le net comme par exemple la doc Ubuntu.


Outils de la page

Outils du site